Arreglos o arrays en funciones en pseudocodigo

pseint_base_web

Hola a todos, hoy os explicare como podemos usar los arreglos o arrays en las funciones en pseudocódigo.

Antes de empezar, aquí te dejo el post con el manual sobre las funciones en pseudocódigo.

Usar arrays o arreglos en funciones de pseudocódigo es facil, lo único que debemos hacer es pasar el array como parámetro, ademas de todo aquello que necesitemos. Veamos un ejemplo, para sumar los valores de un array.

SubProceso suma <- suma_valores(num, TAMANIO)
	definir suma como entero;
	Para i<-1 Hasta TAMANIO Con Paso 1 Hacer
		suma=suma+num[i];
	Fin Para

Fin SubProceso

Proceso Prueba

	Definir num como entero;
	Definir i como entero;
	Definir TAMANIO como entero;
	TAMANIO=5;
	Dimension num[TAMANIO];

	Para i<-1 Hasta TAMANIO Con Paso 1 Hacer
		Escribir "Escribe un valor para el indice ",i;
		leer num[i];
	Fin Para
	escribir "La suma de los valores del array es ",suma_valores(num, TAMANIO);
FinProceso

Como vemos, hemos pasado como parámetro el array o arreglo y la constante usada para saber el tamaño del array o arreglo.

Espero que os sea de ayuda. Si teneis dudas, preguntad. Estamos para ayudarte.

Etiquetas

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *