Instrucción de control condicional en Pseudocódigo

pseint_base_web

Hola a todos, hoy os explicare las instrucciones de control condicionales, que son, como utilizarlas y algunos ejemplos.

Una instrucción de control condicional es un bloque de código que se ejecuta si cumple una condición, que nosotros pongamos. Esta condición es una expresión lógica que debe dar como resultado true o false, para ello es habitual usar los operadores relacionales y lógicos.

Las dos mas utilizadas son:

  • Condicional simple: si la condición es verdadera se ejecuta el bloque de código que contenga y ya esta. Su sintaxis es:

SI (condición) Entonces

Instrucciones

Fin-Si

Por ejemplo:


Inicio
   Leer numero1
   Si (numero1>0) Entonces
      Escribir numero1 " es mayor que 0"
   FinSi
 Fin

  • Condicional doble: si la condición es verdadera se ejecuta el bloque de código que contenga y sino se cumple pues ejecuta otro bloque de codigo. Ejecuta uno o otro. Su sintaxis es:

SI (condición) Entonces

Instrucciones

Sino

Instrucciones

Fin-Si

Por ejemplo:

Inicio
    Leer numero1
    Si (numero1>0) Entonces
       Escribir numero1 " es mayor que 0"
    Sino
       Escribir numero1 " es menor que 0"
    FinSi
 Fin

Algo que se suele hacer es anidar estructuras Si, se puede usar para especificar aun mas una condición  Debemos recordar que debemos cerrar las estructuras Si que abramos, es recomendable tabular las instrucciones para mayor legibilidad. Veamos un ejemplo:

 Inicio
    Si (condicion) Entonces
       Si (condicion) Entonces
          Instrucciones
       Sino
          Intrucciones
       FinSi
    Sino
       Instrucciones
    FinSi
 Fin
 

También existe otra instrucción de control condicional, llamado segun sea, que según un valor (de una variable, una constante, etc.)  o expresión hace una operación u otra. No puede ser una condición. Su sintaxis es:

Segun (valor o expresion) hacer

valor1:

Instrucciones

valor2:

Instrucciones

….

FinSegun

Por ejemplo:

Inicio
 Leer mes
 Segun mes Hacer
    1:
       escribir "Enero"
    2:
       escribir "Febrero"
    3:
       escribir "Marzo"
    4:
       escribir "Abril"
    5:
       escribir "Mayo"
    6:
       escribir "Junio"
    7:
       escribir "Julio"
    8:
       escribir "Agosto"
    9:
       escribir "Septiembre"
    10:
       escribir "Octubre"
    11:
       escribir "Noviembre"
    12:
       escribir "Diciembre"
 FinSegun
Fin

Espero que os sea de ayuda.

Etiquetas

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *