Arreglos o arrays multidimensionales en pseudocódigo

Hola a todos, hoy os mostrare como definir y utilizar arreglos o arrays multidimensionales en pseudocódigo.

Los arreglos o arrays multidimensionales son varios arrays unidimensionales unidos. Para imaginártelo mejor, piensa que son como tablas, donde los valores son el contenido de la tabla.

Veamos como se definen:

Proceso Prueba

	definir num como entero;

	dimension num[3,3];

FinProceso

Lo único que cambia es que añadimos es otro numero, el primero hace referencia a las filas (como en los unidimensionales) y el segundo es el numero de columna. Es decir, que sería como una tabla de 3×3.

Vams a ver como podemos recorrerlo:

Proceso Prueba

	definir num, columna, fila como entero;
	dimension num[3,3];

	num[1,1]=1;
	num[1,2]=2;
	num[1,3]=3;
	num[2,1]=4;
	num[2,2]=5;
	num[2,3]=6;
	num[3,1]=7;
	num[3,2]=8;
	num[3,3]=9;

	Para columna<-1 Hasta 3 Con Paso 1 Hacer
		Para fila<-1 Hasta 3 Con Paso 1 Hacer
			escribir num[columna,fila];
		FinPara
	FinPara
FinProceso

Como vemos, usamos un bucle dentro de otro bucle, necesitaremos un bucle por cada array unidimensional. Para entenderlo mejor veamos este ejemplo para ver la combinación de indices:

Proceso Prueba

	definir num, columna, fila como entero;
	dimension num[3,3];

	num[1,1]=1;
	num[1,2]=2;
	num[1,3]=3;
	num[2,1]=4;
	num[2,2]=5;
	num[2,3]=6;
	num[3,1]=7;
	num[3,2]=8;
	num[3,3]=9;

	Para columna<-1 Hasta 3 Con Paso 1 Hacer
		Para fila<-1 Hasta 3 Con Paso 1 Hacer
			escribir "En la columna ",columna," y fila ",fila," es ",num[columna,fila];
		FinPara
	FinPara
FinProceso

¿Pero que pasa si, para un concreto caso, queremos ver una columna en concreto sin tener que recorrer todas las columnas? Podemos hacerlo con un simple bucle. Veamos un ejemplo:

Proceso Prueba

	definir num, columna, fila como entero;
	dimension num[3,3];

	num[1,1]=1;
	num[1,2]=2;
	num[1,3]=3;
	num[2,1]=4;
	num[2,2]=5;
	num[2,3]=6;
	num[3,1]=7;
	num[3,2]=8;
	num[3,3]=9;

	Para fila<-1 Hasta 3 Con Paso 1 Hacer
		Escribir num[2, fila];
	FinPara
FinProceso

En el ejemplo anterior, vemos que mostramos solo la columna dos.

También podemos hacer como en los arrays unidimensionales, introducir nosotros los datos. Aquí lo vemos:

Proceso Prueba

	definir num, columna, fila como entero;
	dimension num[3,3];

	Para columna<-1 Hasta 3 Con Paso 1 Hacer
		Para fila<-1 Hasta 3 Con Paso 1 Hacer
			escribir "Introduce el valor de la columna ",columna," y ",fila;
                        leer num[columna,fila];
		FinPara
	FinPara

	Para columna<-1 Hasta 3 Con Paso 1 Hacer
		Para fila<-1 Hasta 3 Con Paso 1 Hacer
			escribir "En la columna ",columna," y fila ",fila," es ",num[columna,fila];
		FinPara
	FinPara
FinProceso

Por último, haremos igual que en los arrays unidimensionales,  que es definir una constante para que en caso de cambiar el tamaño de un array solo lo hagamos en un lugar. Veamos un ejemplo:

Proceso Prueba

	definir num, columna, fila,TAMANIO_COLUMNA, TAMANIO_FILA como entero;
	TAMANIO_COLUMNA=3;
	TAMANIO_FILA=3;

	dimension num[TAMANIO_COLUMNA,TAMANIO_FILA];
	Para columna<-1 Hasta TAMANIO_COLUMNA Con Paso 1 Hacer
		Para fila<-1 Hasta TAMANIO_FILA Con Paso 1 Hacer
			escribir "Introduce el valor de la columna ",columna," y ",fila;
			leer num[columna,fila];
		FinPara
	FinPara

	Para columna<-1 Hasta TAMANIO_COLUMNA Con Paso 1 Hacer
		Para fila<-1 Hasta TAMANIO_FILA Con Paso 1 Hacer
			escribir "En la columna ",columna," y fila ",fila," es ",num[columna,fila];
		FinPara
	FinPara
FinProceso

Espero que os sea de ayuda. Si teneis dudas, preguntad. Estamos para ayudarte.

Etiquetas

11 comments

  1. Gran explicación

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *